Back to overview
Degraded

Users unable to log into Ours Privacy app

Sep 15 at 02:00pm CDT
Affected services
Admin Application

Resolved
Sep 15 at 03:01pm CDT

The login issues impacting access to the Ours Privacy app have been resolved.

Created
Sep 15 at 02:00pm CDT

The login issues impacting access to the Ours Privacy app have been resolved. The root cause was an outage with our third-party authentication provider, Clerk.

During this period, only login access was affected. Event ingestion and dispatching to destinations remained fully operational throughout the incident.

Clerk has restored normal service, and we have confirmed stable performance. We will continue to monitor closely, but no further impact is expected.

Thank you for your patience while this was resolved.