Back to overview
Degraded

Intermittent login & dashboard access issues

Feb 19, 2026 at 04:24pm UTC
Affected services
Admin Application

Resolved
Feb 19, 2026 at 05:23pm UTC

This incident is resolved. Login and dashboard access are back to normal after recovery from our authentication provider (Clerk). We’re continuing to monitor, but we’re no longer seeing elevated errors. There was no data loss, and no core product functionality was degraded beyond the temporary login/dashboard access interruption.

If you’re still having trouble, please refresh and try again, or contact support.

Created
Feb 19, 2026 at 04:24pm UTC

We’re seeing intermittent failures when logging in and loading the dashboard for a subset of users. This is related to an incident with our third-party authentication provider (Clerk). Service appears to be recovering, but you may still see occasional errors.

If you’re impacted, please try refreshing and signing in again. We’re actively monitoring and coordinating on a fix, and we’ll post updates here as we learn more. No data loss is expected.